Command Run on Window 8.1pro machine docker-compose up

aneesakhter@VE170817_A MINGW64 /e/vue-storefront-api (master)
$ docker-compose up
vuestorefrontapi_redis_1 is done
Starting elasticsearch … error

ERROR: for elasticsearch Cannot start service es1: OCI runtime create failed: c
ontainer_linux.go:345: starting container process caused “process_linux.go:424:
container init caused “rootfs_linux.go:58: mounting \”/e/vue-storefront-api/d
ocker/elasticsearch/config/elasticsearch.yml\” to rootfs \"/mnt/sda1/var/lib
/docker/overlay2/e6ef457dc1f2a862079672e5d19d10d63bf986249424c13428d0e89f5877977
6/merged\" at \"/mnt/sda1/var/lib/docker/overlay2/e6ef457dc1f2a862079672e5d1
9d10d63bf986249424c13428d0e89f58779776/merged/usr/share/elasticsearch/config/ela
sticsearch.yml\" caused \“not a directory\”"": unknown: Are you trying to
mount a directory onto a file (or vice-versa)? Check if the specified host path
exists and is the expected type

ERROR: for es1 Cannot start service es1: OCI runtime create failed: container_l
inux.go:345: starting container process caused “process_linux.go:424: container
init caused “rootfs_linux.go:58: mounting \”/e/vue-storefront-api/docker/elas
ticsearch/config/elasticsearch.yml\” to rootfs \"/mnt/sda1/var/lib/docker/ov
erlay2/e6ef457dc1f2a862079672e5d19d10d63bf986249424c13428d0e89f58779776/merged\
" at \"/mnt/sda1/var/lib/docker/overlay2/e6ef457dc1f2a862079672e5d19d10d63bf9
86249424c13428d0e89f58779776/merged/usr/share/elasticsearch/config/elasticsearch
.yml\" caused \“not a directory\”"": unknown: Are you trying to mount a d
irectory onto a file (or vice-versa)? Check if the specified host path exists an
d is the expected type
ERROR: Encountered errors while bringing up the project.

please check this topic https://stackoverflow.com/questions/42203488/settings-to-windows-firewall-to-allow-docker-for-windows-to-share-drive/43904051 and let us know if it helped :slight_smile:

I did check as per your suggestion everything is fine but not working.show same error.
My window version : Window 8.1 pro

I had the same problem. What i found for temporary solution is to delete elasticsearch.yml in vue-storefront-api/docker/elasticsearch/config/

By doing this i was able to launch it. Btw i also had to go in docker settings -> share my drive -> reset -> share C: ->apply

I did check as per your suggestion but i have same problem

$ docker-compose up
vuestorefrontapi_redis_1 is done
Starting elasticsearch … error

ERROR: for elasticsearch Cannot start service es1: OCI runtime create failed: c
ontainer_linux.go:345: starting container process caused “process_linux.go:424:
container init caused “rootfs_linux.go:58: mounting \”/e/vue-storefront-api/d
ocker/elasticsearch/config/elasticsearch.yml\” to rootfs “/mnt/sda1/var/lib
/docker/overlay2/e6ef457dc1f2a862079672e5d19d10d63bf986249424c13428d0e89f5877977
6/merged” at “/mnt/sda1/var/lib/docker/overlay2/e6ef457dc1f2a862079672e5d1
9d10d63bf986249424c13428d0e89f58779776/merged/usr/share/elasticsearch/config/ela
sticsearch.yml” caused \“not a directory\”"": unknown: Are you trying to
mount a directory onto a file (or vice-versa)? Check if the specified host path
exists and is the expected type

ERROR: for es1 Cannot start service es1: OCI runtime create failed: container_l
inux.go:345: starting container process caused “process_linux.go:424: container
init caused “rootfs_linux.go:58: mounting \”/e/vue-storefront-api/docker/elas
ticsearch/config/elasticsearch.yml\” to rootfs “/mnt/sda1/var/lib/docker/ov
erlay2/e6ef457dc1f2a862079672e5d19d10d63bf986249424c13428d0e89f58779776/merged
" at “/mnt/sda1/var/lib/docker/overlay2/e6ef457dc1f2a862079672e5d19d10d63bf9
86249424c13428d0e89f58779776/merged/usr/share/elasticsearch/config/elasticsearch
.yml” caused \“not a directory\””": unknown: Are you trying to mount a d
irectory onto a file (or vice-versa)? Check if the specified host path exists an
d is the expected type
ERROR: Encountered errors while bringing up the project.

ok so you have to delete this line under the volume section in the docker-compose.yml file from vue-storefront-api folder :

  • ./docker/elasticsearch/config/elasticsearch.yml:/usr/share/elasticsearch/config/elasticsearch.yml:ro

the purpose of this line is to copy the .yml file into the container.

i did check as per your suggestion but show the below error.
vue-storefront-api/docker-compose.yml
version: ‘3.0’
services:
es1:
container_name: elasticsearch
build: docker/elasticsearch/
volumes:
- ./docker/elasticsearch/data:/usr/share/elasticsearch/data
ports:
- ‘9200:9200’
- ‘9300:9300’
environment:
ES_JAVA_OPTS: “-Xmx512m -Xms512m”

kibana:
build: docker/kibana/
volumes:
- ./docker/kibana/config/:/usr/share/kibana/config:ro
ports:
- ‘5601:5601’
depends_on:
- es1

redis:
image: ‘redis:4-alpine’
ports:
- ‘6379:6379’

volumes:
esdat1:

aneesakhter@VE170817_A MINGW64 /e/vuewindostore/vue-storefront-api (master)
$ docker-compose up
Creating network “vuestorefrontapi_default” with the default driver
Creating elasticsearch … done
Creating vuestorefrontapi_redis_1 … done
Creating vuestorefrontapi_kibana_1 … done
Attaching to elasticsearch, vuestorefrontapi_redis_1, vuestorefrontapi_kibana_1
redis_1 | 1:C 05 Jul 03:25:40.536 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO
0Oo
redis_1 | 1:C 05 Jul 03:25:40.537 # Redis version=4.0.14, bits=64, commit=0000
0000, modified=0, pid=1, just started
redis_1 | 1:C 05 Jul 03:25:40.538 # Warning: no config file specified, using t
he default config. In order to specify a config file use redis-server /path/to/r
edis.conf
kibana_1 | FATAL CLI ERROR Error: ENOENT: no such file or directory, open ‘/usr
/share/kibana/config/kibana.yml’
kibana_1 | at Error (native)
kibana_1 | at Object.fs.openSync (fs.js:642:18)
kibana_1 | at fs.readFileSync (fs.js:510:33)
kibana_1 | at files.map.path (/usr/share/kibana/src/cli/serve/read_yaml_con
fig.js:10:78)
kibana_1 | at Array.map (native)
kibana_1 | at exports.default (/usr/share/kibana/src/cli/serve/read_yaml_co
nfig.js:10:23)
kibana_1 | at readServerSettings (/usr/share/kibana/src/cli/serve/serve.js:
48:51)
kibana_1 | at getCurrentSettings (/usr/share/kibana/src/cli/serve/serve.js:
110:16)
kibana_1 | at Command. (/usr/share/kibana/src/cli/serve/serve.js
:112:24)
kibana_1 | at next (native)
vuestorefrontapi_kibana_1 exited with code 1
elasticsearch | OpenJDK 64-Bit Server VM warning: If the number of processors is
expected to increase from one, then you should configure the number of parallel
GC threads appropriately using -XX:ParallelGCThreads=N
elasticsearch | [2019-07-05T03:26:23,380][INFO ][o.e.n.Node ] [] i
nitializing …
elasticsearch | [2019-07-05T03:26:23,476][WARN ][o.e.b.ElasticsearchUncaughtExce
ptionHandler] [] uncaught exception in thread [main]
elasticsearch | org.elasticsearch.bootstrap.StartupException: java.lang.IllegalS
tateException: Failed to create node environment
elasticsearch | at org.elasticsearch.bootstrap.Elasticsearch.init(Elasti
csearch.java:136) ~[elasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.bootstrap.Elasticsearch.execute(Ela
sticsearch.java:123) ~[elasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.cli.EnvironmentAwareCommand.execute
(EnvironmentAwareCommand.java:70) ~[elasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.cli.Command.mainWithoutErrorHandlin
g(Command.java:134) ~[elasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.cli.Command.main(Command.java:90) ~
[elasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.bootstrap.Elasticsearch.main(Elasti
csearch.java:91) ~[elasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.bootstrap.Elasticsearch.main(Elasti
csearch.java:84) ~[elasticsearch-5.6.11.jar:5.6.11]
elasticsearch | Caused by: java.lang.IllegalStateException: Failed to create nod
e environment
elasticsearch | at org.elasticsearch.node.Node.(Node.java:268) ~[e
lasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.node.Node.(Node.java:245) ~[e
lasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.bootstrap.Bootstrap$5.(Bootst
rap.java:233) ~[elasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap
.java:233) ~[elasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.
java:342) ~[elasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.bootstrap.Elasticsearch.init(Elasti
csearch.java:132) ~[elasticsearch-5.6.11.jar:5.6.11]
elasticsearch | … 6 more
elasticsearch | Caused by: java.nio.file.AccessDeniedException: /usr/share/elast
icsearch/data/nodes
elasticsearch | at sun.nio.fs.UnixException.translateToIOException(UnixE
xception.java:84) ~[?:?]
elasticsearch | at sun.nio.fs.UnixException.rethrowAsIOException(UnixExc
eption.java:102) ~[?:?]
elasticsearch | at sun.nio.fs.UnixException.rethrowAsIOException(UnixExc
eption.java:107) ~[?:?]
elasticsearch | at sun.nio.fs.UnixFileSystemProvider.createDirectory(Uni
xFileSystemProvider.java:384) ~[?:?]
elasticsearch | at java.nio.file.Files.createDirectory(Files.java:674) ~
[?:1.8.0_181]
elasticsearch | at java.nio.file.Files.createAndCheckIsDirectory(Files.j
ava:781) ~[?:1.8.0_181]
elasticsearch | at java.nio.file.Files.createDirectories(Files.java:767)
~[?:1.8.0_181]
elasticsearch | at org.elasticsearch.env.NodeEnvironment.(NodeEnvi
ronment.java:221) ~[elasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.node.Node.(Node.java:265) ~[e
lasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.node.Node.(Node.java:245) ~[e
lasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.bootstrap.Bootstrap$5.(Bootst
rap.java:233) ~[elasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap
.java:233) ~[elasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.
java:342) ~[elasticsearch-5.6.11.jar:5.6.11]
elasticsearch | at org.elasticsearch.bootstrap.Elasticsearch.init(Elasti
csearch.java:132) ~[elasticsearch-5.6.11.jar:5.6.11]
elasticsearch | … 6 more
elasticsearch exited with code 1

you have this error with file or line deleted or with both ? try with only the line from the file deleted.

I have deleted file vue-storefront-api/docker/elasticsearch/config/elasticsearch.yml and line (/docker/elasticsearch/config/elasticsearch.yml:/usr/share/elasticsearch/config/elasticsearch.yml:ro) deleted in this vue-storefront-api/docker-compose.yml

aneesakhter@VE170817_A MINGW64 /e/vuewindostore/vue-storefront-api (master)
$ docker-compose down
Stopping vuestorefrontapi_kibana_1 … done
Stopping vuestorefrontapi_redis_1 … done
Removing vuestorefrontapi_kibana_1 … done
Removing elasticsearch … done
Removing vuestorefrontapi_redis_1 … done
Removing network vuestorefrontapi_default

aneesakhter@VE170817_A MINGW64 /e/vuewindostore/vue-storefront-api (master)
$ docker-compose build
Building es1
Step 1/2 : FROM docker.elastic.co/elasticsearch/elasticsearch:5.6.11
—> b99307834e26
Step 2/2 : RUN bin/elasticsearch-plugin remove x-pack --purge
—> Using cache
—> 3bc3e99431d8
Successfully built 3bc3e99431d8
Successfully tagged vuestorefrontapi_es1:latest
Building kibana
Step 1/2 : FROM docker.elastic.co/kibana/kibana:5.6.11
—> 72543213daee
Step 2/2 : RUN bin/kibana-plugin remove x-pack && kibana 2>&1 | grep -m 1 “O
ptimization of .* complete”
—> Using cache
—> fe243b472f10
Successfully built fe243b472f10
Successfully tagged vuestorefrontapi_kibana:latest
redis uses an image, skipping

aneesakhter@VE170817_A MINGW64 /e/vuewindostore/vue-storefront-api (master)
$ docker-compose up
Creating network “vuestorefrontapi_default” with the default driver
Creating vuestorefrontapi_redis_1 … done
Creating elasticsearch … done
Creating vuestorefrontapi_kibana_1 … done
Attaching to vuestorefrontapi_redis_1, elasticsearch, vuestorefrontapi_kibana_1
redis_1 | 1:C 05 Jul 10:54:36.825 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO
0Oo
redis_1 | 1:C 05 Jul 10:54:36.826 # Redis version=4.0.14, bits=64, commit=0000
0000, modified=0, pid=1, just started
elasticsearch | OpenJDK 64-Bit Server VM warning: If the number of processors is
expected to increase from one, then you should configure the number of parallel
GC threads appropriately using -XX:ParallelGCThreads=N
redis_1 | 1:C 05 Jul 10:54:36.826 # Warning: no config file specified, using t
he default config. In order to specify a config file use redis-server /path/to/r
edis.conf
redis_1 | 1:M 05 Jul 10:54:36.828 * Running mode=standalone, port=6379.
redis_1 | 1:M 05 Jul 10:54:36.830 # WARNING: The TCP backlog setting of 511 ca
nnot be enforced because /proc/sys/net/core/somaxconn is set to the lower value
of 128.
elasticsearch | OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x0000
000085330000, 2060255232, 0) failed; error=‘Cannot allocate memory’ (errno=12)
redis_1 | 1:M 05 Jul 10:54:36.830 # Server initialized
elasticsearch | #
redis_1 | 1:M 05 Jul 10:54:36.831 # WARNING overcommit_memory is set to 0! Bac
kground save may fail under low memory condition. To fix this issue add ‘vm.over
commit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysct
l vm.overcommit_memory=1’ for this to take effect.
elasticsearch | # There is insufficient memory for the Java Runtime Environment
to continue.
elasticsearch | # Native memory allocation (mmap) failed to map 2060255232 bytes
for committing reserved memory.
elasticsearch | # An error report file with more information is saved as:
elasticsearch | # /usr/share/elasticsearch/hs_err_pid1.log
elasticsearch exited with code 1
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:43Z”,“tags”:[“warning”,
“config”],“pid”:1,“message”:“Settings for “xpack” were not applied, check for
spelling errors and ensure the plugin is loaded.”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:43Z”,“tags”:[“status”,"
plugin:kibana@5.6.11",“info”],“pid”:1,“state”:“green”,“message”:“Status changed
from uninitialized to green - Ready”,“prevState”:“uninitialized”,“prevMsg”:“unin
itialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:43Z”,“tags”:[“status”,"
plugin:elasticsearch@5.6.11",“info”],“pid”:1,“state”:“yellow”,“message”:“Status
changed from uninitialized to yellow - Waiting for Elasticsearch”,“prevState”:“u
ninitialized”,“prevMsg”:“uninitialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:43Z”,“tags”:[“error”,“e
lasticsearch”,“admin”],“pid”:1,“message”:“Request error, retrying\nHEAD http://e
lasticsearch:9200/ => getaddrinfo ENOTFOUND elasticsearch elasticsearch:9200”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:43Z”,“tags”:[“status”,"
plugin:console@5.6.11",“info”],“pid”:1,“state”:“green”,“message”:“Status changed
from uninitialized to green - Ready”,“prevState”:“uninitialized”,“prevMsg”:“uni
nitialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:43Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:43Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:43Z”,“tags”:[“status”,"
plugin:elasticsearch@5.6.11",“error”],“pid”:1,“state”:“red”,“message”:“Status ch
anged from yellow to red - Unable to connect to Elasticsearch at http://elastics
earch:9200.”,“prevState”:“yellow”,“prevMsg”:“Waiting for Elasticsearch”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:43Z”,“tags”:[“status”,"
plugin:metrics@5.6.11",“info”],“pid”:1,“state”:“green”,“message”:“Status changed
from uninitialized to green - Ready”,“prevState”:“uninitialized”,“prevMsg”:“uni
nitialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:43Z”,“tags”:[“status”,"
plugin:timelion@5.6.11",“info”],“pid”:1,“state”:“green”,“message”:“Status change
d from uninitialized to green - Ready”,“prevState”:“uninitialized”,“prevMsg”:“un
initialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:43Z”,“tags”:[“listening
“,“info”],“pid”:1,“message”:“Server running at http://0:5601”}
kibana_1 | {“type”:“log”,”@timestamp”:“2019-07-05T10:54:43Z”,“tags”:[“status”,"
ui settings",“error”],“pid”:1,“state”:“red”,“message”:“Status changed from unini
tialized to red - Elasticsearch plugin is red”,“prevState”:“uninitialized”,“prev
Msg”:“uninitialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:46Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:46Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:48Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:48Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:51Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:51Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:53Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:53Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:56Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:56Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:58Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:54:58Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:01Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:01Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:03Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:03Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:06Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:06Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:08Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:08Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:11Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:11Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:13Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:13Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:16Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:16Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:19Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:19Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:21Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:21Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:24Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:24Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:26Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:26Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:29Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:29Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:31Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:31Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:34Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:34Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:36Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:36Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:39Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:39Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:42Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:42Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:44Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:44Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:47Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:47Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:49Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:49Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:52Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:52Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:54Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:54Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:57Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:57Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:59Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:55:59Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:56:02Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:56:02Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:56:04Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:56:04Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:56:07Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:56:07Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:56:09Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:56:09Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:56:12Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:56:12Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:56:14Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:56:14Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:56:17Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:56:17Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-05T10:56:19Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}

ok, try with only the line deleted. Create a new elasticsearch.yml, the default config in this file was :

cluster.name: “docker-cluster”
network.host: 0.0.0.0
discovery.zen.minimum_master_nodes: 1
discovery.type: single-node

Did you check if your docker settings -> shared drive was good ? When you reset docker’s settings you must enter your login information.

Which directory create new elasticsearch.yml?please provide the directory path.

What did you means this line “ok, try with only the line deleted”

aneesakhter@VE170817_A MINGW64 /e/vuewindostore/vue-storefront-api (master)
$ docker-compose down
Stopping vuestorefrontapi_kibana_1 … done
Removing vuestorefrontapi_kibana_1 … done
Removing vuestorefrontapi_redis_1 … done
Removing elasticsearch … done
Removing network vuestorefrontapi_default

aneesakhter@VE170817_A MINGW64 /e/vuewindostore/vue-storefront-api (master)
$ docker-compose build
Building es1
Step 1/2 : FROM docker.elastic.co/elasticsearch/elasticsearch:5.6.11
—> b99307834e26
Step 2/2 : RUN bin/elasticsearch-plugin remove x-pack --purge
—> Using cache
—> 3bc3e99431d8
Successfully built 3bc3e99431d8
Successfully tagged vuestorefrontapi_es1:latest
Building kibana
Step 1/2 : FROM docker.elastic.co/kibana/kibana:5.6.11
—> 72543213daee
Step 2/2 : RUN bin/kibana-plugin remove x-pack && kibana 2>&1 | grep -m 1
ptimization of .* complete"
—> Using cache
—> fe243b472f10
Successfully built fe243b472f10
Successfully tagged vuestorefrontapi_kibana:latest
redis uses an image, skipping

aneesakhter@VE170817_A MINGW64 /e/vuewindostore/vue-storefront-api (master)
$ docker-compose up
Creating network “vuestorefrontapi_default” with the default driver
Creating vuestorefrontapi_redis_1 … done
Creating elasticsearch … done
Creating vuestorefrontapi_kibana_1 … done
Attaching to vuestorefrontapi_redis_1, elasticsearch, vuestorefrontapi_kibana_1
redis_1 | 1:C 08 Jul 10:43:12.244 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO
0Oo
elasticsearch | OpenJDK 64-Bit Server VM warning: If the number of processors is
expected to increase from one, then you should configure the number of parallel
GC threads appropriately using -XX:ParallelGCThreads=N
redis_1 | 1:C 08 Jul 10:43:12.245 # Redis version=4.0.14, bits=64, commit=0000
0000, modified=0, pid=1, just started
redis_1 | 1:C 08 Jul 10:43:12.245 # Warning: no config file specified, using t
he default config. In order to specify a config file use redis-server /path/to/r
edis.conf
redis_1 | 1:M 08 Jul 10:43:12.247 * Running mode=standalone, port=6379.
redis_1 | 1:M 08 Jul 10:43:12.249 # WARNING: The TCP backlog setting of 511 ca
nnot be enforced because /proc/sys/net/core/somaxconn is set to the lower value
of 128.
elasticsearch | OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x0000
000085330000, 2060255232, 0) failed; error=‘Cannot allocate memory’ (errno=12)
elasticsearch | #
redis_1 | 1:M 08 Jul 10:43:12.250 # Server initialized
redis_1 | 1:M 08 Jul 10:43:12.250 # WARNING overcommit_memory is set to 0! Bac
kground save may fail under low memory condition. To fix this issue add ‘vm.over
commit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysct
l vm.overcommit_memory=1’ for this to take effect.
elasticsearch | # There is insufficient memory for the Java Runtime Environment
to continue.
elasticsearch | # Native memory allocation (mmap) failed to map 2060255232 bytes
for committing reserved memory.
elasticsearch | # An error report file with more information is saved as:
elasticsearch | # /usr/share/elasticsearch/hs_err_pid1.log
elasticsearch exited with code 1
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-08T10:37:22Z”,“tags”:[“warning”,
“config”],“pid”:1,“message”:“Settings for “xpack” were not applied, check for
spelling errors and ensure the plugin is loaded.”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-08T10:37:23Z”,“tags”:[“status”,"
plugin:kibana@5.6.11",“info”],“pid”:1,“state”:“green”,“message”:“Status changed
from uninitialized to green - Ready”,“prevState”:“uninitialized”,“prevMsg”:“unin
itialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-08T10:37:23Z”,“tags”:[“status”,"
plugin:elasticsearch@5.6.11",“info”],“pid”:1,“state”:“yellow”,“message”:“Status
changed from uninitialized to yellow - Waiting for Elasticsearch”,“prevState”:“u
ninitialized”,“prevMsg”:“uninitialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-08T10:37:23Z”,“tags”:[“error”,“e
lasticsearch”,“admin”],“pid”:1,“message”:“Request error, retrying\nHEAD http://e
lasticsearch:9200/ => getaddrinfo ENOTFOUND elasticsearch elasticsearch:9200”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-08T10:37:23Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-08T10:37:23Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-08T10:37:23Z”,“tags”:[“status”,"
plugin:elasticsearch@5.6.11",“error”],“pid”:1,“state”:“red”,“message”:“Status ch
anged from yellow to red - Unable to connect to Elasticsearch at http://elastics
earch:9200.”,“prevState”:“yellow”,“prevMsg”:“Waiting for Elasticsearch”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-08T10:37:23Z”,“tags”:[“status”,"
plugin:console@5.6.11",“info”],“pid”:1,“state”:“green”,“message”:“Status changed
from uninitialized to green - Ready”,“prevState”:“uninitialized”,“prevMsg”:“uni
nitialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-08T10:37:23Z”,“tags”:[“status”,"
plugin:metrics@5.6.11",“info”],“pid”:1,“state”:“green”,“message”:“Status changed
from uninitialized to green - Ready”,“prevState”:“uninitialized”,“prevMsg”:“uni
nitialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-08T10:37:23Z”,“tags”:[“status”,"
plugin:timelion@5.6.11",“info”],“pid”:1,“state”:“green”,“message”:“Status change
d from uninitialized to green - Ready”,“prevState”:“uninitialized”,“prevMsg”:“un
initialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-08T10:37:23Z”,“tags”:[“listening
“,“info”],“pid”:1,“message”:“Server running at http://0:5601”}
kibana_1 | {“type”:“log”,”@timestamp”:“2019-07-08T10:37:23Z”,“tags”:[“status”,"
ui settings",“error”],“pid”:1,“state”:“red”,“message”:“Status changed from unini
tialized to red - Elasticsearch plugin is red”,“prevState”:“uninitialized”,“prev
Msg”:“uninitialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-08T10:37:25Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}

Please look into issue

aneesakhter@VE170817_A MINGW64 /e/vuewindostore/vue-storefront-api (master)
$ docker-compose down
Removing vuestorefrontapi_kibana_1 … done
Removing elasticsearch … done
Removing vuestorefrontapi_redis_1 … done
Removing network vuestorefrontapi_default

aneesakhter@VE170817_A MINGW64 /e/vuewindostore/vue-storefront-api (master)
$ docker-compose build
Building es1
Step 1/2 : FROM docker.elastic.co/elasticsearch/elasticsearch:5.6.11
—> b99307834e26
Step 2/2 : RUN bin/elasticsearch-plugin remove x-pack --purge
—> Using cache
—> 3bc3e99431d8
Successfully built 3bc3e99431d8
Successfully tagged vuestorefrontapi_es1:latest
Building kibana
Step 1/2 : FROM docker.elastic.co/kibana/kibana:5.6.11
—> 72543213daee
Step 2/2 : RUN bin/kibana-plugin remove x-pack && kibana 2>&1 | grep -m 1 “O
ptimization of .* complete”
—> Using cache
—> fe243b472f10
Successfully built fe243b472f10
Successfully tagged vuestorefrontapi_kibana:latest
redis uses an image, skipping

aneesakhter@VE170817_A MINGW64 /e/vuewindostore/vue-storefront-api (master)
$ docker-compose up
Creating network “vuestorefrontapi_default” with the default driver
Creating elasticsearch … done
Creating vuestorefrontapi_redis_1 … done
Creating vuestorefrontapi_kibana_1 … done
Attaching to vuestorefrontapi_redis_1, elasticsearch, vuestorefrontapi_kibana_1
redis_1 | 1:C 17 Jul 08:27:29.505 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO
0Oo
redis_1 | 1:C 17 Jul 08:27:29.506 # Redis version=4.0.14, bits=64, commit=0000
0000, modified=0, pid=1, just started
redis_1 | 1:C 17 Jul 08:27:29.506 # Warning: no config file specified, using t
he default config. In order to specify a config file use redis-server /path/to/r
edis.conf
redis_1 | 1:M 17 Jul 08:27:29.571 * Running mode=standalone, port=6379.
redis_1 | 1:M 17 Jul 08:27:29.572 # WARNING: The TCP backlog setting of 511 ca
nnot be enforced because /proc/sys/net/core/somaxconn is set to the lower value
of 128.
redis_1 | 1:M 17 Jul 08:27:29.572 # Server initialized
redis_1 | 1:M 17 Jul 08:27:29.573 # WARNING overcommit_memory is set to 0! Bac
kground save may fail under low memory condition. To fix this issue add ‘vm.over
commit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysct
l vm.overcommit_memory=1’ for this to take effect.
elasticsearch | OpenJDK 64-Bit Server VM warning: If the number of processors is
expected to increase from one, then you should configure the number of parallel
GC threads appropriately using -XX:ParallelGCThreads=N
elasticsearch | OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x0000
000085330000, 2060255232, 0) failed; error=‘Cannot allocate memory’ (errno=12)
elasticsearch | #
elasticsearch | # There is insufficient memory for the Java Runtime Environment
to continue.
elasticsearch | # Native memory allocation (mmap) failed to map 2060255232 bytes
for committing reserved memory.
elasticsearch | # An error report file with more information is saved as:
elasticsearch | # /usr/share/elasticsearch/hs_err_pid1.log
elasticsearch exited with code 1
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:42Z”,“tags”:[“warning”,
“config”],“pid”:1,“message”:“Settings for “xpack” were not applied, check for
spelling errors and ensure the plugin is loaded.”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:43Z”,“tags”:[“status”,"
plugin:kibana@5.6.11",“info”],“pid”:1,“state”:“green”,“message”:“Status changed
from uninitialized to green - Ready”,“prevState”:“uninitialized”,“prevMsg”:“unin
itialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:43Z”,“tags”:[“status”,"
plugin:elasticsearch@5.6.11",“info”],“pid”:1,“state”:“yellow”,“message”:“Status
changed from uninitialized to yellow - Waiting for Elasticsearch”,“prevState”:“u
ninitialized”,“prevMsg”:“uninitialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:43Z”,“tags”:[“status”,"
plugin:console@5.6.11",“info”],“pid”:1,“state”:“green”,“message”:“Status changed
from uninitialized to green - Ready”,“prevState”:“uninitialized”,“prevMsg”:“uni
nitialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:43Z”,“tags”:[“status”,"
plugin:metrics@5.6.11",“info”],“pid”:1,“state”:“green”,“message”:“Status changed
from uninitialized to green - Ready”,“prevState”:“uninitialized”,“prevMsg”:“uni
nitialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:44Z”,“tags”:[“error”,“e
lasticsearch”,“admin”],“pid”:1,“message”:“Request error, retrying\nHEAD http://e
lasticsearch:9200/ => getaddrinfo ENOTFOUND elasticsearch elasticsearch:9200”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:44Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:44Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:44Z”,“tags”:[“status”,"
plugin:timelion@5.6.11",“info”],“pid”:1,“state”:“green”,“message”:“Status change
d from uninitialized to green - Ready”,“prevState”:“uninitialized”,“prevMsg”:“un
initialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:44Z”,“tags”:[“status”,"
plugin:elasticsearch@5.6.11",“error”],“pid”:1,“state”:“red”,“message”:“Status ch
anged from yellow to red - Unable to connect to Elasticsearch at http://elastics
earch:9200.”,“prevState”:“yellow”,“prevMsg”:“Waiting for Elasticsearch”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:44Z”,“tags”:[“listening
“,“info”],“pid”:1,“message”:“Server running at http://0:5601”}
kibana_1 | {“type”:“log”,”@timestamp”:“2019-07-17T08:27:44Z”,“tags”:[“status”,"
ui settings",“error”],“pid”:1,“state”:“red”,“message”:“Status changed from unini
tialized to red - Elasticsearch plugin is red”,“prevState”:“uninitialized”,“prev
Msg”:“uninitialized”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:46Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:46Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:49Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:49Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:52Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:52Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:54Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:54Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:57Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:57Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:59Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:27:59Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:28:02Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:28:02Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:28:04Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:28:04Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:28:07Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:28:07Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:28:09Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:28:09Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“No living connections”}
kibana_1 | {“type”:“log”,"@timestamp":“2019-07-17T08:28:12Z”,“tags”:[“warning”,
“elasticsearch”,“admin”],“pid”:1,“message”:“Unable to revive connection: http://
elasticsearch:9200/”}