DOMException: "Node cannot be inserted at the specified point in the hierarchy"

Witam,
mam taki błąd tylko na środowisku produkcyjnym.
domexception
Występuje on losowo. Na Chrome rzadziej a na Firefox częściej.
Jak namierzyć co powoduje ten błąd?

Translation by Google

Hello,
I have this error only in the production environment.
domexception
It occurs randomly. On Chrome, less often and on Firefox more often.
How to track what causes this error?

Ten sam błąd w Chrome (the same error in Chrome browser)
domexception_chrome

Hi @czak - please do use English in this Forum, it’ll be much easier to get help.
This issue is related - probably- to lazy loading of the components @patzick had something similar in the past related to Wishlist and Compare components. Forgive me but I forgot what solved this issue back then :slight_smile:

I noticed that the problem appears after adding the ‘vue-multiselect’ component.
Why?
Change in SortBy.vue

Hi @pkarw I am also getting the same issue when I enable Cloud-flare for my VSF domain. It does work perfectly without Cloud-flare in development and production both environments. I am surprised that Cloud-flare can affect the coding as well. Would you please guide me on this if you have something?

I guess it can as from what you’re saying it seems to me that the cached (cloudflare) HTML no longer matches the CSR generated virtual DOM. Details: https://ssr.vuejs.org/guide/hydration.html