Error 500: The signature is invalid. Verify and try again

Hello everyone and congratulations again for creating this framework!

I am trying to implement SSL on my nginx docker container, in view of the deployment that will take place on AWS ECS, but i have some problems.

My technologies and related versions:

  • Magento 2.4.1
  • Vue Storefront 1.12.2
  • Vue Storefront API 1.12.3
  • Mage2vuestorefront 1.11.12

The container seems to work correctly, so the site is navigable in SSL, the frontend with Vue Storefront is correctly displayed with a certificate, as well as the back office with access to Magento.

However, I have problems when calls are made to the container that manages the API (vue storefront api - port 8080). For some strange reason it seems that Magento refuses to answer, reporting this error:
{"code":500,"result":{"errorMessage":"The signature is invalid. Verify and try again.","code":401}}

Here is part of my nginx configuration:
server {
listen 80;
return 301 https://$host$request_uri;
}

server {
    listen 443 ssl http2 default_server;
    ssl_certificate /etc/ssl/certs/server.crt;
    ssl_certificate_key /etc/ssl/certs/server.key;
    ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
    server_name dev.real_host.it;

    [...]

# vue storefront frontend
location / {
  proxy_pass http://vsf_nodejs:3000/;
}

# vue storefront frontend assets
location /assets/ {
  proxy_pass http://vsf_nodejs:3000/assets/;
}

# vue storefront api
location /api/ {
  proxy_pass http://vsf_api_nodejs:8080/api/;
}

# vue storefront api img
location /img/ {
  proxy_pass http://vsf_api_nodejs:8080/img/;
}

   [...]

I tried to make various attempts, and I also discovered the point where it breaks on Magento:
vendor/magento/framework/Oauth/Oauth.php::204

I don’t understand if it is necessary to configure something on the API application, on the container node that manages it or if there is a starting problem on the certificate that was generated and passed to me. Unfortunately I am quite ignorant about SSL certificates, I tried to assemble the .ca-bundle file and the .crt file into one .crt and assign it back to nginx, but nothing has changed. Can anyone help me?

Thank you so much,
Michael