Getting error only in production mode

Recently I turned into the error in production mode.
If I run a store in development mode It works fine but when I start production mode It’s fire error.
Error:
"DOMException: Failed to execute ‘appendChild’ on ‘Node’: This node type does not support this method. at Object.appendChild"

Can anyone tell me, how to debug this type of error?

Reproduce error steps

  1. Load category listing page
  2. If I refresh the page then this error appears

Here is my console visualization for reference
image

This issue is related to the CSR/SSR DOM mismatch. We discussed it on Slack - it’s probably related to breadcrumbs issue. Please do compare the server and client’s html. There must be an issue probably related by the async call to catalog/setupBreadcrumb

@pkarw
After checking the CSR/SSR DOM. I have sawn both generate the same visualization but I tried something new and found there is an issue with the HTML entity code I used in the breadcrumb.

Solution
I directly use the HTML instead of the code and my problem will fix. But don’t know what is the difference at time of SSR and CSR?

Before:
<span class="px-2">&sol;</span>

After
/

I have this problem when updated version from 1.9 to 1.10.rc.1. I add somthing to cart go to checkout and click f5 after reload I got home page with this problem…

@EliotRaven / @chirag.viradiya do you still encounter this issue? Can you please check the clean installation? We haven’t noticed problems like this

I added to alias in webpack.base.config ‘vue$’: ‘vue/dist/vue.esm.js’, and all fixed

Hello @chirag.viradiya @pkarw
I am getting the same error while loading homepage on my production setup. Would you please help me?

Error : vue.runtime.esm.js:1888 DOMException: Failed to execute ‘appendChild’ on ‘Node’: This node type does not support this method.

1 Like

@Dhruvi
You must have to check inside the code, there are missing the HTML tags or unsupported syntax like &sol;

Hello @chirag.viradiya I m facing this issue only after logged in to account and refresh any page. Without login everything works fine.

@Dhruvi and @chirag.viradiya this issue has been fixed in 1.10.5 (released Today) - it seemingly doesn’t exist in 1.11 anymore as well

1 Like