Issue with elasticsearch & TypeScript - v1.12.1

On some queries my elasticsearch responses contain an error:

{"code":500,"result":"⨯ Unable to compile TypeScript:\nsrc/processor/default.ts(25,23): error TS2339: Property 'query' does not exist on type 'Request<any, any, any, any>'.\nsrc/processor/default.ts(25,59): error TS2339: Property 'query' does not exist on type 'Request<any, any, any, any>'.\n"}[

This happens after I restart the docker containers after a fresh install, no adjustments made. Any help with this would be highly appreciated!

[search] Can not connect the vue-storefront-api / ElasticSearch instance! Error: {"code":500,"result":"⨯ Unable to compile TypeScript:\nsrc/processor/default
.ts(25,23): error TS2339: Property 'query' does not exist on type 'Request<any, any, any, any>'.\nsrc/processor/default.ts(25,59): error TS2339: Property 'query' does
not exist on type 'Request<any, any, any, any>'.\n"}
app_1  |     at SearchAdapter.exports.modules../core/lib/search/adapter/api/searchAdapter.ts.SearchAdapter.handleResult (vsf-search-adapter-api-searchAdapter.server-b
undle.js:183:23)
app_1  |     at Object.resultProcessor (vsf-search-adapter-api-searchAdapter.server-bundle.js:221:30)
app_1  |     at server-bundle.js:4285:92
app_1  |     at process._tickCallback (internal/process/next_tick.js:68:7)
app_1  | (node:368) UnhandledPromiseRejectionWarning: Error: {"code":500,"result":"⨯ Unable to compile TypeScript:\nsrc/processor/default.ts(25,23): error TS2339: Pro
perty 'query' does not exist on type 'Request<any, any, any, any>'.\nsrc/processor/default.ts(25,59): error TS2339: Property 'query' does not exist on type 'Request<a
ny, any, any, any>'.\n"}

more error example.

This seems to be a really weird bug happening or something, I can run the Vue Storefront API in legacy mode ( ES, Redis & Kibana in Docker & API locally with yarn dev ) and this works fine but when I run the API in docker it stops me from being able to do any curl request to my elasticsearch. I did not run into this issue previous time I made a Vue Storefront Project which was with version 1.11.2.