New theme Capybara installation problem

Hi, i try to initiate the instalation of the new theme Capybara on our vuestorefront repo. Our repo and vsf-api setting are working like a charm with the default theme.

After installing the Capybara theme, i got an error while compiling with yarn.

/home/gaboguit/git/vsf/src/themes/capybara/webpack.config.js:94
fixPostCSSPlugins(mergedConfig.module.rules);
^
TypeError: Cannot read property ‘rules’ of undefined
at module.exports (/home/gaboguit/git/vsf/src/themes/capybara/webpack.config.js:94:41)
at Object. (/home/gaboguit/git/vsf/core/build/dev-server.js:11:20)
at Module._compile (internal/modules/cjs/loader.js:1158:30)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:1178:10)
at Module.load (internal/modules/cjs/loader.js:1002:32)
at Function.Module._load (internal/modules/cjs/loader.js:901:14)
at Module.require (internal/modules/cjs/loader.js:1044:19)
at require (internal/modules/cjs/helpers.js:77:18)
at Object. (/home/gaboguit/git/vsf/core/scripts/server.ts:57:3)
at Module._compile (internal/modules/cjs/loader.js:1158:30)
error Command failed with exit code 1.

Anyone had this error before?

Thank you

Fixed by recompiling from the master branch.

Thank you

1 Like

Cool! Great to hear you solved it. Any contributions / feedback are welcome!