PLEASE HELP!cannot launch the vsf app on server. Localhost:3000 redirecting to /error

Please help!

I have tested the app all fine on local machine thus i follow the production guide to launch on server.

Nginx ssl is all set, i have testes myURL.com/api is working fine!
BUT myURL.com/ cause redirect loop.

I do: curl localhost:3000 on server and it returned:

FOUND. Rediecting to /error

Can anyone please help? As i need to launch the shop asap.

Thanks in advance!

Probably the reason lays in the lack of the connectivity between Vue Storefront application and the vue-storefront-api / Elasticsearch. Please make sure the vue-storefront app (probably run on Docker container?) has the connectivity to the URL address set in the config.elasticsearch.host. Typically it’s a problem with the Docker based naming service - and You could probably add the proper entry to the etc/hosts file or use any other publicly available url address in the elasticsearch section instead.

Dear @Pkarw

I found out it is not really compiling for my vsf app after syncing version of node /npm to my local machine.

It showed this error and cannot compile.

I have a feeling that it is getting closer to suceed. Can you please help?

Many many thanks!

I have sucessfully compile the app, but still directing to /error.

I did try to change VSF/config/local.json elasticsearch> host to the server URL in my local machine to test, at home (localhost:3000) the console pop-up like this:58

i copy the link and paste in another window, and it is displaying the data correctly.

Got stuck on this for four days… really hope it can be solved!
Thanks again

this is the server error log, not sure if this caused the issue?

I run ‘npm run dev’ and try to check with the api.
Strange thing happened:
it’s fine with just https://www.daifuku.club/api/catalog/vue_storefront_catalog/product/_search



but if there’s query after _search (e.g. ?xhfhsdkjsndfksf )
it will show disconnect error…
really not sure why

turn out there is a URL string limit at nginx, i reassign it and the ‘npm run dev’ version app is running on server now (but not stable)

i can test through and check the console, not sure if the following warnings is the reason or develop version cannot by pass ? will that be the reason letting the ‘yarn build’ app directing to /error?

00
32

Hii, i am running vue-storefront on apache server please help to which step following details

Hello, I have the same problem in VueStoreFront. Can’t find out the solution.

Please make sure your api instance is up am running and there is no connectivity issue between vsf and vsfapi

Hi, thank you for the input. Yes, it was running. The problem, in my case, was a redirect that have been solved by changing localhost to 0.0.0.0.

experiencing the same issue. I am recreating the tutorial steps using docker, on linux mint. Essentially receiving an error page instead of the application. When using the very first tutorial (this is the introduction docker one) it does work perfectly.

Here is the error.

 [search] Can not connect the vue-storefront-api / ElasticSearch instance! Error: {"root_cause":[{"type":"index_not_found_exception","reason":"no such index","resource.type":"index_or_alias","resource.id":"vue_storefront_catalog","index_uuid":"_na_","index":"vue_storefront_catalog"}],"type":"index_not_found_exception","reason":"no such index","resource.type":"index_or_alias","resource.id":"vue_storefront_catalog","index_uuid":"_na_","index":"vue_storefront_catalog"}

My docker files are as follows,

CONTAINER ID        IMAGE                     COMMAND                  CREATED             STATUS              PORTS                                            NAMES
5a936c790a59        vuestorefront_app         "docker-entrypoint.s…"   7 minutes ago       Up 7 minutes                                                         vuestorefront_app_1
ad65bd2eef6c        vuestorefrontapi_kibana   "/bin/bash /usr/loca…"   21 minutes ago      Up 21 minutes       0.0.0.0:5601->5601/tcp                           vuestorefrontapi_kibana_1
4a502500e4ea        vuestorefrontapi_app      "docker-entrypoint.s…"   21 minutes ago      Up 21 minutes       0.0.0.0:8080->8080/tcp                           vuestorefrontapi_app_1
6f78fc26a0f6        vuestorefrontapi_es1      "/bin/bash bin/es-do…"   21 minutes ago      Up 21 minutes       0.0.0.0:9200->9200/tcp, 0.0.0.0:9300->9300/tcp   elasticsearch
6204f53e349b        redis:4-alpine            "docker-entrypoint.s…"   21 minutes ago      Up 21 minutes       0.0.0.0:6379->6379/tcp                           vuestorefrontapi_redis_1

And everything else is just the default docker files.

API appears to be working fine. Really confusing issue.

Please make sure your configs in the VSF are properly set to connect to ElasticSearch via elasticsearch virtual host name and not by localhost that probably is not working with the docker setup anymore

@kkdg please make sure our docs are covering this case

Noted, working on it.